What’s Vulnerable › Vulnerabilities

CVE-2021-28813: Insufficiently Protected Credentials Vulnerability in QSW-M2116P-2T2S and QuNetSwitch

Description

A vulnerability involving insecure storage of sensitive information has been reported to affect QSW-M2116P-2T2S and QNAP switches running QuNetSwitch. If exploited, this vulnerability allows remote attackers to read sensitive information by accessing the unrestricted storage mechanism.We have already fixed this vulnerability in the following versions: QSW-M2116P-2T2S 1.0.6 build 210713 and later QGD-1600P: QuNetSwitch 1.0.6.1509 and later QGD-1602P: QuNetSwitch 1.0.6.1509 and later QGD-3014PT: QuNetSwitch 1.0.6.1519 and later

Affected products

How to fix

Upgrade to a fixed version: QNAP Qsw-M2116P-2T2S Firmware 1.0.6; QNAP Systems Inc. QuNetSwitch 1.0.6.1509. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28813 or the next vulnerability affects your stack