What’s Vulnerable › Vulnerabilities
CVE-2021-28814: Improper Access Control Vulnerability in Helpdesk
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-269
Description
An improper access control vulnerability has been reported to affect QNAP NAS. If exploited, this vulnerability allows remote attackers to compromise the security of the software. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.4.
Affected products
- QNAP Systems Inc. Helpdesk: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Helpdesk 3.0.4. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-25
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-25
Get alerted when CVE-2021-28814 or the next vulnerability affects your stack