What’s Vulnerable › Vulnerabilities
CVE-2021-28816: Stack Buffer Overflow Vulnerabilities in QTS, QuTS hero, and QuTScloud
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-10 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack buffer overflow vulnerability has been reported to affect QNAP device running QTS, QuTScloud, QuTS hero. If exploited, this vulnerability allows attackers to execute arbitrary code. We have already fixed this vulnerability in the following versions of QTS, QuTScloud, QuTS hero: QTS 4.5.4.1715 build 20210630 and later QTS 5.0.0.1716 build 20210701 and later QTS 4.3.3.1693 build 20210624 and later QTS 4.3.6.1750 build 20210730 and later QuTScloud c4.5.6.1755 and later QuTS hero h4.5.4.1771 build 20210825 and later
Affected products
- QNAP QTS: before 4.3.3.1693; from 4.3.4 before 4.3.6.1750; from 4.4.0 before 4.5.4.1715; from 5.0.0 before 5.0.0.1716 — fixed in 4.3.3.1693, 4.3.6.1750, 4.5.4.1715, 5.0.0.1716
- QNAP Systems Inc. QuTS hero: before h4.5.4.1771 — fixed in h4.5.4.1771
- QNAP Systems Inc. QuTScloud: before c4.5.6.1755 — fixed in c4.5.6.1755
How to fix
Upgrade to a fixed version: QNAP QTS 4.3.3.1693, 4.3.6.1750, 4.5.4.1715, 5.0.0.1716; QNAP Systems Inc. QuTS hero h4.5.4.1771; QNAP Systems Inc. QuTScloud c4.5.6.1755. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-33
- https://www.qnap.com/en/security-advisory/qsa-21-33
Get alerted when CVE-2021-28816 or the next vulnerability affects your stack