What’s Vulnerable › Vulnerabilities
CVE-2021-28832
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-05 · updated 2026-06-17
Description
VSCodeVim before 1.19.0 allows attackers to execute arbitrary code via a crafted workspace configuration.
Affected products
- Vim Project Vim: before 1.19.0 — fixed in 1.19.0
How to fix
Upgrade to a fixed version: Vim Project Vim 1.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/VSCodeVim/Vim/commit/939df0e7fd55a9840dbd4fb3c907315e2a5ef446
- https://marketplace.visualstudio.com/items?itemName=vscodevim.vim
- https://vuln.ryotak.me/advisories/9
- https://github.com/VSCodeVim/Vim/commit/939df0e7fd55a9840dbd4fb3c907315e2a5ef446
- https://marketplace.visualstudio.com/items?itemName=vscodevim.vim
- https://vuln.ryotak.me/advisories/9
Get alerted when CVE-2021-28832 or the next vulnerability affects your stack