What’s Vulnerable › Vulnerabilities
CVE-2021-28835
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow vulnerability in XNView before 2.50, allows local attackers to execute arbitrary code via crafted GEM bitmap file.
Affected products
- XnView: before 2.50 — fixed in 2.50
How to fix
Upgrade to a fixed version: XnView 2.50. Check the vendor advisory for mitigations.
References
- https://newsgroup.xnview.com/viewtopic.php?f=35&t=44679
- https://www.xnview.com/en/xnview/#changelog
- https://newsgroup.xnview.com/viewtopic.php?f=35&t=44679
- https://www.xnview.com/en/xnview/#changelog
Get alerted when CVE-2021-28835 or the next vulnerability affects your stack