What’s Vulnerable › Vulnerabilities
CVE-2021-28848
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-03 · updated 2026-06-17
- Weakness: CWE-770
Description
Mintty before 3.4.5 allows remote servers to cause a denial of service (Windows GUI hang) by telling the Mintty window to change its title repeatedly at high speed, which results in many SetWindowTextA or SetWindowTextW calls. In other words, it does not implement a usleep or similar delay upon processing a title change.
Affected products
- mintty: before 3.4.5 — fixed in 3.4.5
How to fix
Upgrade to a fixed version: mintty 3.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/mintty/mintty/commit/bd52109993440b6996760aaccb66e68e782762b9
- https://github.com/mintty/mintty/compare/3.4.4...3.4.5
- https://mintty.github.io/
- https://github.com/mintty/mintty/commit/bd52109993440b6996760aaccb66e68e782762b9
- https://github.com/mintty/mintty/compare/3.4.4...3.4.5
- https://mintty.github.io/
Get alerted when CVE-2021-28848 or the next vulnerability affects your stack