What’s Vulnerable › Vulnerabilities

CVE-2021-28938

Description

Siren Federate before 6.8.14-10.3.9, 6.9.x through 7.6.x before 7.6.2-20.2, 7.7.x through 7.9.x before 7.9.3-21.6, 7.10.x before 7.10.2-22.2, and 7.11.x before 7.11.2-23.0 can leak user information across thread contexts. This occurs in opportunistic circumstances when there is concurrent query execution by a low-privilege user and a high-privilege user. The former query might run with the latter query's privileges.

Affected products

How to fix

Upgrade to a fixed version: Siren Federate 6.8.14-10.3.9, 7.10.2-22.2, 7.6.2-20.2, 7.9.3-21.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28938 or the next vulnerability affects your stack