What’s Vulnerable › Vulnerabilities
CVE-2021-28953
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-21 · updated 2026-06-17
- Weakness: CWE-427
Description
The unofficial C/C++ Advanced Lint extension before 1.9.0 for Visual Studio Code allows attackers to execute arbitrary binaries if the user opens a crafted repository.
Affected products
- C/C++ Advanced Lint Project C/C++ Advanced Lint: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: C/C++ Advanced Lint Project C/C++ Advanced Lint 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/jbenden/vscode-c-cpp-flylint/compare/v1.8.2...v1.9.0
- https://marketplace.visualstudio.com/items?itemName=jbenden.c-cpp-flylint
- https://vuln.ryotak.me/advisories/16
- https://github.com/jbenden/vscode-c-cpp-flylint/compare/v1.8.2...v1.9.0
- https://marketplace.visualstudio.com/items?itemName=jbenden.c-cpp-flylint
- https://vuln.ryotak.me/advisories/16
Get alerted when CVE-2021-28953 or the next vulnerability affects your stack