What’s Vulnerable › Vulnerabilities

CVE-2021-28965

Description

The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues. An incorrect document can be produced after parsing and serializing.

Affected products

How to fix

Upgrade to a fixed version: ruby rexml 3.2.5; Ruby 2.6.7, 2.7.3, 3.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28965 or the next vulnerability affects your stack