What’s Vulnerable › Vulnerabilities

CVE-2021-28972

Description

In drivers/pci/hotplug/rpadlpar_sysfs.c in the Linux kernel through 5.11.8, the RPA PCI Hotplug driver has a user-tolerable buffer overflow when writing a new device name to the driver from userspace, allowing userspace to write data to the kernel stack frame directly. This occurs because add_slot_store and remove_slot_store mishandle drc_name '\0' termination, aka CID-cc7a0bb058b8.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.227, 4.4.263, 5.10.26, 5.11.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28972 or the next vulnerability affects your stack