What’s Vulnerable › Vulnerabilities
CVE-2021-29069
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects XR450 before 2.3.2.114, XR500 before 2.3.2.114, and WNR2000v5 before 1.0.0.76.
Affected products
- NETGEAR Wnr2000V5 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR Xr450 Firmware: before 2.3.2.114 — fixed in 2.3.2.114
- NETGEAR Xr500 Firmware: before 2.3.2.114 — fixed in 2.3.2.114
How to fix
Upgrade to a fixed version: NETGEAR Wnr2000V5 Firmware 1.0.0.76; NETGEAR Xr450 Firmware 2.3.2.114; NETGEAR Xr500 Firmware 2.3.2.114. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063023/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0595
- https://kb.netgear.com/000063023/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0595
Get alerted when CVE-2021-29069 or the next vulnerability affects your stack