What’s Vulnerable › Vulnerabilities
CVE-2021-29090
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-02 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper neutralization of special elements used in an SQL command ('SQL Injection') vulnerability in PHP component in Synology Photo Station before 6.8.14-3500 allows remote authenticated users to execute arbitrary SQL command via unspecified vectors.
Affected products
- Synology Photo Station: from 6.8 before 6.8.14-3500 — fixed in 6.8.14-3500
How to fix
Upgrade to a fixed version: Synology Photo Station 6.8.14-3500. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_20_20
- https://www.synology.com/security/advisory/Synology_SA_20_20
Get alerted when CVE-2021-29090 or the next vulnerability affects your stack