What’s Vulnerable › Vulnerabilities
CVE-2021-29105: There is a stored Cross Site Scripting (XSS) vulnerability in Esri ArcGIS Server Services Directory version 10.8.1 and below.
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross Site Scripting (XSS) vulnerability in Esri ArcGIS Server Services Directory version 10.8.1 and below may allow a remote authenticated attacker to pass and store malicious strings in the ArcGIS Services Directory.
Affected products
- Esri ArcGIS Server: before 10.9.0 — fixed in 10.9.0
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 10.9.0. Check the vendor advisory for mitigations.
References
- https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/arcgis-server-security-2021-update-1-patch/
- https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/arcgis-server-security-2021-update-1-patch/
Get alerted when CVE-2021-29105 or the next vulnerability affects your stack