What’s Vulnerable › Vulnerabilities
CVE-2021-29106: There is a reflected Cross Site Scripting (XSS) vulnerability in Esri ArcGIS Server version 10.8.1 and below.
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected Cross Site Scripting (XSS) vulnerability in Esri ArcGIS Server version 10.8.1 and below may allow a remote attacker able to convince a user to click on a crafted link which could potentially execute arbitrary JavaScript code in the user’s browser.
Affected products
- Esri ArcGIS Server: before 10.9.0 — fixed in 10.9.0
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 10.9.0. Check the vendor advisory for mitigations.
References
- https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/arcgis-server-security-2021-update-1-patch/
- https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/arcgis-server-security-2021-update-1-patch/
Get alerted when CVE-2021-29106 or the next vulnerability affects your stack