What’s Vulnerable › Vulnerabilities
CVE-2021-29133
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-24 · updated 2026-06-17
Description
Lack of verification in haserl, a component of Alpine Linux Configuration Framework, before 0.9.36 allows local users to read the contents of any file on the filesystem.
Affected products
- Haserl Project Haserl: before 0.9.36 — fixed in 0.9.36
How to fix
Upgrade to a fixed version: Haserl Project Haserl 0.9.36. Check the vendor advisory for mitigations.
References
- https://github.com/rapid7/metasploit-framework/pull/14833
- https://github.com/rapid7/metasploit-framework/pull/14833/commits/5bf6b2d094deb22fa8183ce161b90cbe4fd40a70
- https://gitlab.alpinelinux.org/alpine/aports/-/issues/12539
- https://twitter.com/steaIth/status/1364940271054712842
- https://github.com/rapid7/metasploit-framework/pull/14833
- https://github.com/rapid7/metasploit-framework/pull/14833/commits/5bf6b2d094deb22fa8183ce161b90cbe4fd40a70
- https://gitlab.alpinelinux.org/alpine/aports/-/issues/12539
- https://twitter.com/steaIth/status/1364940271054712842
Get alerted when CVE-2021-29133 or the next vulnerability affects your stack