What’s Vulnerable › Vulnerabilities

CVE-2021-29154

Description

BPF JIT compilers in the Linux kernel through 5.11.12 have incorrect computation of branch displacements, allowing them to execute arbitrary code within the kernel context. This affects arch/x86/net/bpf_jit_comp.c and arch/x86/net/bpf_jit_comp32.c.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.230, 4.19.186, 4.4.266, 4.9.266. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-29154 or the next vulnerability affects your stack