What’s Vulnerable › Vulnerabilities
CVE-2021-29213
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-01 · updated 2026-06-17
Description
A potential local bypass of security restrictions vulnerability has been identified in HPE ProLiant DL20 Gen10, HPE ProLiant ML30 Gen10, and HPE ProLiant MicroServer Gen10 Plus server's system ROMs prior to version 2.52. The vulnerability could be locally exploited to cause disclosure of sensitive information, denial of service (DoS), and/or compromise system integrity.
Affected products
- HPE Proliant Dl20 Gen10 Server Firmware: before 2.52 — fixed in 2.52
- HPE Proliant Microserver Gen10 Plus Firmware: before 2.52 — fixed in 2.52
- HPE Proliant Ml30 Gen10 Server Firmware: before 2.52 — fixed in 2.52
How to fix
Upgrade to a fixed version: HPE Proliant Dl20 Gen10 Server Firmware 2.52; HPE Proliant Microserver Gen10 Plus Firmware 2.52; HPE Proliant Ml30 Gen10 Server Firmware 2.52. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf04197en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf04197en_us
Get alerted when CVE-2021-29213 or the next vulnerability affects your stack