What’s Vulnerable › Vulnerabilities
CVE-2021-29219
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-120
Description
A potential local buffer overflow vulnerability has been identified in HPE FlexNetwork 5130 EL Switch Series version: Prior to 5130_EI_7.10.R3507P02. HPE has made the following software update to resolve the vulnerability in HPE FlexNetwork 5130 EL Switch Series version 5130_EL_7.10.R3507P02.
Affected products
- HPE Flexnetwork 5130 Jg932A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg933A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg934A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg936A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg937A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg940A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
- HPE Flexnetwork 5130 Jg941A Firmware: before 5130_ei_7.10.r3507p02 — fixed in 5130_ei_7.10.r3507p02
How to fix
Upgrade to a fixed version: HPE Flexnetwork 5130 Jg932A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg933A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg934A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg936A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg937A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg940A Firmware 5130_ei_7.10.r3507p02; HPE Flexnetwork 5130 Jg941A Firmware 5130_ei_7.10.r3507p02. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbnw04234en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbnw04234en_us
Get alerted when CVE-2021-29219 or the next vulnerability affects your stack