What’s Vulnerable › Vulnerabilities
CVE-2021-29238
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-03 · updated 2026-06-17
- Weakness: CWE-352
Description
CODESYS Automation Server before 1.16.0 allows cross-site request forgery (CSRF).
Affected products
- CODESYS Automation Server: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: CODESYS Automation Server 1.16.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14638&token=30b75ee95d0d94527894dfd8cdc5432575a8eff8&download=
- https://www.codesys.com/security/security-reports.html
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14638&token=30b75ee95d0d94527894dfd8cdc5432575a8eff8&download=
- https://www.codesys.com/security/security-reports.html
Get alerted when CVE-2021-29238 or the next vulnerability affects your stack