What’s Vulnerable › Vulnerabilities
CVE-2021-29239
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-03 · updated 2026-06-17
- Weakness: CWE-345
Description
CODESYS Development System 3 before 3.5.17.0 displays or executes malicious documents or files embedded in libraries without first checking their validity.
Affected products
- CODESYS Development System: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
How to fix
Upgrade to a fixed version: CODESYS Development System 3.5.17.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14639&token=fa836f8bd4a2184aa9323a639ca9f2aaf1538412&download=
- https://www.codesys.com/security/security-reports.html
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14639&token=fa836f8bd4a2184aa9323a639ca9f2aaf1538412&download=
- https://www.codesys.com/security/security-reports.html
Get alerted when CVE-2021-29239 or the next vulnerability affects your stack