What’s Vulnerable › Vulnerabilities
CVE-2021-29240
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-04 · updated 2026-06-17
Description
The Package Manager of CODESYS Development System 3 before 3.5.17.0 does not check the validity of packages before installation and may be used to install CODESYS packages with malicious content.
Affected products
- CODESYS Development System: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
How to fix
Upgrade to a fixed version: CODESYS Development System 3.5.17.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14636&token=1ce7e6e4cbe4651989ede418450d7c82e972bdf2&download=
- https://www.codesys.com/security/security-reports.html
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14636&token=1ce7e6e4cbe4651989ede418450d7c82e972bdf2&download=
- https://www.codesys.com/security/security-reports.html
Get alerted when CVE-2021-29240 or the next vulnerability affects your stack