What’s Vulnerable › Vulnerabilities
CVE-2021-29242
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-03 · updated 2026-06-17
- Weakness: CWE-20
Description
CODESYS Control Runtime system before 3.5.17.0 has improper input validation. Attackers can send crafted communication packets to change the router's addressing scheme and may re-route, add, remove or change low level communication packages.
Affected products
- CODESYS Control for BeagleBone SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control For Empc-A/Imx6 Sl: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for IOT2000 SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for Linux ARM SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for Linux SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for PFC100 SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for PFC200 SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for PLCnext SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for Raspberry Pi SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 3.0 before 4.1.0.0 — fixed in 4.1.0.0
- CODESYS Control Rte: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Control Runtime System Toolkit: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Control Win: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Edge Gateway: from 3.0 before 3.5.17.0; from 3.0 before 4.1.0.0 — fixed in 3.5.17.0, 4.1.0.0
- CODESYS Embedded Target Visu Toolkit: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Gateway Server V2: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Hmi: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Opc Server: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS PLCHandler: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Remote Target Visu Toolkit: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Safety Sil: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
- CODESYS Simulation Runtime: from 3.0 before 3.5.17.0 — fixed in 3.5.17.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.1.0.0; CODESYS Control For Empc-A/Imx6 Sl 4.1.0.0; CODESYS Control for IOT2000 SL 4.1.0.0; CODESYS Control for Linux ARM SL 4.1.0.0; CODESYS Control for Linux SL 4.1.0.0; CODESYS Control for PFC100 SL 4.1.0.0; CODESYS Control for PFC200 SL 4.1.0.0; CODESYS Control for PLCnext SL 4.1.0.0; CODESYS Control for Raspberry Pi SL 4.1.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.1.0.0; CODESYS Control Rte 3.5.17.0; CODESYS Control Runtime System Toolkit 3.5.17.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14640&token=623b6fceb0579ef0f7505e29beefa5b3f8ac7873&download=
- https://www.codesys.com/security/security-reports.html
- https://customers.codesys.com/index.php
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=14640&token=623b6fceb0579ef0f7505e29beefa5b3f8ac7873&download=
- https://www.codesys.com/security/security-reports.html
Get alerted when CVE-2021-29242 or the next vulnerability affects your stack