What’s Vulnerable › Vulnerabilities
CVE-2021-29249
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-26 · updated 2026-06-17
Description
BTCPay Server before 1.0.6.0, when the payment button is used, has a privacy vulnerability.
Affected products
- btcpayserver/btcpayserver: before 1.0.6.0 — fixed in 1.0.6.0
How to fix
Upgrade to a fixed version: btcpayserver/btcpayserver 1.0.6.0. Check the vendor advisory for mitigations.
References
- https://blog.btcpayserver.org/btcpay-server-1-0-6-0/
- https://github.com/btcpayserver/btcpayserver/releases
- https://blog.btcpayserver.org/btcpay-server-1-0-6-0/
- https://github.com/btcpayserver/btcpayserver/releases
Get alerted when CVE-2021-29249 or the next vulnerability affects your stack