What’s Vulnerable › Vulnerabilities
CVE-2021-29251
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-01 · updated 2026-06-17
Description
BTCPay Server before 1.0.7.1 mishandles the policy setting in which users can register (in Server Settings > Policies). This affects Docker use cases in which a mail server is configured.
Affected products
- btcpayserver/btcpayserver: before 1.0.7.1 — fixed in 1.0.7.1
How to fix
Upgrade to a fixed version: btcpayserver/btcpayserver 1.0.7.1. Check the vendor advisory for mitigations.
References
- https://blog.btcpayserver.org/vulnerability-disclosure-v1-0-7-0/
- https://github.com/btcpayserver/btcpayserver/releases/tag/v1.0.7.1
- https://blog.btcpayserver.org/vulnerability-disclosure-v1-0-7-0/
- https://github.com/btcpayserver/btcpayserver/releases/tag/v1.0.7.1
Get alerted when CVE-2021-29251 or the next vulnerability affects your stack