What’s Vulnerable › Vulnerabilities
CVE-2021-29266
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-26 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the Linux kernel before 5.11.9. drivers/vhost/vdpa.c has a use-after-free because v->config_ctx has an invalid value upon re-opening a character device, aka CID-f6bbf0010ba0.
Affected products
- Linux kernel: from 5.8 before 5.10.26; from 5.11 before 5.11.9 — fixed in 5.10.26, 5.11.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.26, 5.11.9. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.9
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=f6bbf0010ba004f5e90c7aefdebc0ee4bd3283b9
- https://security.netapp.com/advisory/ntap-20210513-0005/
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.9
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=f6bbf0010ba004f5e90c7aefdebc0ee4bd3283b9
- https://security.netapp.com/advisory/ntap-20210513-0005/
Get alerted when CVE-2021-29266 or the next vulnerability affects your stack