What’s Vulnerable › Vulnerabilities
CVE-2021-29281
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-07 · updated 2026-06-17
- Weakness: CWE-434
Description
File upload vulnerability in GFI Mail Archiver versions up to and including 15.1 via insecure implementation of Telerik Web UI plugin which is affected by CVE-2014-2217, and CVE-2017-11317.
Affected products
- GFI Archiver: before 15.2 — fixed in 15.2
How to fix
Upgrade to a fixed version: GFI Archiver 15.2. Check the vendor advisory for mitigations.
References
- https://aminbohio.com/gfi-mail-archiver-15-1-telerik-ui-component-arbitrary-file-upload-unauthenticated-exploit/
- https://cwe.mitre.org/data/definitions/434.html
- https://owasp.org/www-community/vulnerabilities/Unrestricted_File_Upload
- https://www.exploit-db.com/exploits/50181
- https://www.gfi.com/products-and-solutions/network-security-solutions/gfi-archiver
- https://aminbohio.com/gfi-mail-archiver-15-1-telerik-ui-component-arbitrary-file-upload-unauthenticated-exploit/
- https://cwe.mitre.org/data/definitions/434.html
- https://owasp.org/www-community/vulnerabilities/Unrestricted_File_Upload
- https://www.exploit-db.com/exploits/50181
- https://www.gfi.com/products-and-solutions/network-security-solutions/gfi-archiver
Get alerted when CVE-2021-29281 or the next vulnerability affects your stack