What’s Vulnerable › Vulnerabilities
CVE-2021-29300
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-78
Description
The @ronomon/opened library before 1.5.2 is vulnerable to a command injection vulnerability which would allow a remote attacker to execute commands on the system if the library was used with untrusted input.
Affected products
- Ronomon Opened: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Ronomon Opened 1.5.2. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2021-4775
- https://github.com/ronomon/opened/commit/7effe011d4fea8fac7f78c00615e0a6e69af68ec
- https://advisory.checkmarx.net/advisory/CX-2021-4775
- https://github.com/ronomon/opened/commit/7effe011d4fea8fac7f78c00615e0a6e69af68ec
Get alerted when CVE-2021-29300 or the next vulnerability affects your stack