What’s Vulnerable › Vulnerabilities
CVE-2021-29369
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-03 · updated 2026-06-17
- Weakness: CWE-78
Description
The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell metacharacters in Gnuplot commands.
Affected products
- Gnuplot Project Gnuplot: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: Gnuplot Project Gnuplot 0.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/rkesters/gnuplot/commit/23671d4d3d28570fb19a936a6328bfac742410de
- https://www.npmjs.com/package/%40rkesters/gnuplot
- https://github.com/rkesters/gnuplot/commit/23671d4d3d28570fb19a936a6328bfac742410de
- https://www.npmjs.com/package/%40rkesters/gnuplot
Get alerted when CVE-2021-29369 or the next vulnerability affects your stack