What’s Vulnerable › Vulnerabilities
CVE-2021-29399
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
XMB is vulnerable to cross-site scripting (XSS) due to inadequate filtering of BBCode input. This bug affects all versions of XMB. All XMB installations must be updated to versions 1.9.12.03 or 1.9.11.16.
Affected products
- xmbforum2 Xmb: from 1.9.1 before 1.9.11.16; from 1.9.11 before 1.9.11.16; from 1.9.12 before 1.9.12.03 — fixed in 1.9.11.16, 1.9.12.03
How to fix
Upgrade to a fixed version: xmbforum2 Xmb 1.9.11.16, 1.9.12.03. Check the vendor advisory for mitigations.
References
- https://docs.xmbforum2.com/index.php?title=Security_Issue_History
- https://forums.xmbforum2.com/viewthread.php?tid=777105
- https://www.xmbforum2.com/
- https://docs.xmbforum2.com/index.php?title=Security_Issue_History
- https://forums.xmbforum2.com/viewthread.php?tid=777105
- https://www.xmbforum2.com/
Get alerted when CVE-2021-29399 or the next vulnerability affects your stack