What’s Vulnerable › Vulnerabilities
CVE-2021-29417
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-29 · updated 2026-06-17
- Weakness: CWE-22
Description
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
Affected products
- Gitjacker Project Gitjacker: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: Gitjacker Project Gitjacker 0.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/liamg/gitjacker/compare/v0.0.3...v0.1.0
- https://github.com/liamg/gitjacker/releases/tag/v0.1.0
- https://vuln.ryotak.me/advisories/5
- https://github.com/liamg/gitjacker/compare/v0.0.3...v0.1.0
- https://github.com/liamg/gitjacker/releases/tag/v0.1.0
- https://vuln.ryotak.me/advisories/5
Get alerted when CVE-2021-29417 or the next vulnerability affects your stack