What’s Vulnerable › Vulnerabilities
CVE-2021-29424
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-06 · updated 2026-06-17
- Weakness: CWE-704
Description
The Net::Netmask module before 2.0000 for Perl does not properly consider extraneous zero characters at the beginning of an IP address string, which (in some situations) allows attackers to bypass access control that is based on IP addresses.
Affected products
- Fedoraproject Fedora: 32, 33, 34
- Net::Netmask Project Net::Netmask: before 2.0000 — fixed in 2.0000
How to fix
Upgrade to a fixed version: Net::Netmask Project Net::Netmask 2.0000. Check the vendor advisory for mitigations.
References
- https://blog.urth.org/2021/03/29/security-issues-in-perl-ip-address-distros/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CBJVLXJSWN6DKSF5ADUEERI6M23R3GGP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JF4CYIZELC3NISB3RMV4OCI4GYBC557B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y7JIPQAY5OZ5D3DA7INQILU7SGHTHMWB/
- https://metacpan.org/changes/distribution/Net-Netmask#L11-22
- https://security.netapp.com/advisory/ntap-20210604-0007/
- https://blog.urth.org/2021/03/29/security-issues-in-perl-ip-address-distros/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CBJVLXJSWN6DKSF5ADUEERI6M23R3GGP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JF4CYIZELC3NISB3RMV4OCI4GYBC557B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y7JIPQAY5OZ5D3DA7INQILU7SGHTHMWB/
- https://metacpan.org/changes/distribution/Net-Netmask#L11-22
- https://security.netapp.com/advisory/ntap-20210604-0007/
Get alerted when CVE-2021-29424 or the next vulnerability affects your stack