What’s Vulnerable › Vulnerabilities
CVE-2021-29434: Improper validation of URLs ('Cross-site Scripting') in Wagtail rich text fields
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Wagtail is a Django content management system. In affected versions of Wagtail, when saving the contents of a rich text field in the admin interface, Wagtail does not apply server-side checks to ensure that link URLs use a valid protocol. A malicious user with access to the admin interface could thus craft a POST request to publish content with `javascript:` URLs containing arbitrary code. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. See referenced GitHub advisory for additional details, including a workaround. Patched versions have been released as Wagtail 2.11.7 (for the LTS 2.11 branch) and Wagtail 2.12.4 (for the current 2.12 branch).
Affected products
- wagtail: before 2.11.6; from 2.11.0 before 2.11.7; from 2.12.0 before 2.12.4 — fixed in 2.11.6, 2.11.7, 2.12.4
How to fix
Upgrade to a fixed version: wagtail 2.11.6, 2.11.7, 2.12.4. Check the vendor advisory for mitigations.
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-wq5h-f9p5-q7fx
- https://pypi.org/project/wagtail/
- https://github.com/wagtail/wagtail/security/advisories/GHSA-wq5h-f9p5-q7fx
- https://pypi.org/project/wagtail/
Get alerted when CVE-2021-29434 or the next vulnerability affects your stack