What’s Vulnerable › Vulnerabilities
CVE-2021-29438: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.
Affected products
- Nextcloud/Dialogs Project Nextcloud/Dialogs: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: Nextcloud/Dialogs Project Nextcloud/Dialogs 3.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/nextcloud-dialogs/security/advisories/GHSA-g3fq-3v3g-mh32
- https://www.npmjs.com/package/%40nextcloud/dialogs
- https://github.com/nextcloud/nextcloud-dialogs/security/advisories/GHSA-g3fq-3v3g-mh32
- https://www.npmjs.com/package/%40nextcloud/dialogs
Get alerted when CVE-2021-29438 or the next vulnerability affects your stack