What’s Vulnerable › Vulnerabilities
CVE-2021-29439: Plugins can be installed with minimal admin privileges
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-13 · updated 2026-06-17
- Weakness: CWE-863
Description
The Grav admin plugin prior to version 1.10.11 does not correctly verify caller's privileges. As a consequence, users with the permission `admin.login` can install third-party plugins and their dependencies. By installing the right plugin, an attacker can obtain an arbitrary code execution primitive and elevate their privileges on the instance. The vulnerability has been addressed in version 1.10.11. As a mitigation blocking access to the `/admin` path from untrusted sources will reduce the probability of exploitation.
Affected products
- getgrav Grav Admin: before 1.10.11 — fixed in 1.10.11
How to fix
Upgrade to a fixed version: getgrav Grav Admin 1.10.11. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav-plugin-admin/commit/a220359877fd1281f76ba732e5308e0e3002e4b1
- https://github.com/getgrav/grav-plugin-admin/security/advisories/GHSA-wg37-cf5x-55hq
- https://github.com/getgrav/grav-plugin-admin/commit/a220359877fd1281f76ba732e5308e0e3002e4b1
- https://github.com/getgrav/grav-plugin-admin/security/advisories/GHSA-wg37-cf5x-55hq
Get alerted when CVE-2021-29439 or the next vulnerability affects your stack