What’s Vulnerable › Vulnerabilities
CVE-2021-29448: Stored DOM XSS in Pi-hole Admin Web Interface
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Pi-hole is a Linux network-level advertisement and Internet tracker blocking application. The Stored XSS exists in the Pi-hole Admin portal, which can be exploited by the malicious actor with the network access to DNS server. See the referenced GitHub security advisory for patch details.
Affected products
- pi-hole FTL: 5.7
- pi-hole: 5.2.4
- pi-hole web: before 5.5 — fixed in 5.5
How to fix
Upgrade to a fixed version: pi-hole web 5.5. Check the vendor advisory for mitigations.
References
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-cwwf-93p7-73j9
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-cwwf-93p7-73j9
Get alerted when CVE-2021-29448 or the next vulnerability affects your stack