What’s Vulnerable › Vulnerabilities
CVE-2021-29450: WordPress Authenticated disclosure of password-protected posts and pages
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: from 4.7 before 5.7.1 — fixed in 5.7.1
How to fix
Upgrade to a fixed version: WordPress 5.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pmmh-2f36-wvhq
- https://lists.debian.org/debian-lts-announce/2021/04/msg00017.html
- https://wordpress.org/news/category/security/
- https://www.debian.org/security/2021/dsa-4896
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pmmh-2f36-wvhq
- https://lists.debian.org/debian-lts-announce/2021/04/msg00017.html
- https://wordpress.org/news/category/security/
- https://www.debian.org/security/2021/dsa-4896
Get alerted when CVE-2021-29450 or the next vulnerability affects your stack