What’s Vulnerable › Vulnerabilities
CVE-2021-29457: Heap buffer overflow in Exiv2::Jp2Image::doWriteMetadata
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-122
Description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A heap buffer overflow was found in Exiv2 versions v0.27.3 and earlier. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4.
Affected products
- Debian Linux: 9.0, 10.0
- exiv2: before 0.27.4 — fixed in 0.27.4
- Fedoraproject Fedora: 33, 34
How to fix
Upgrade to a fixed version: exiv2 0.27.4. Check the vendor advisory for mitigations.
References
- https://github.com/Exiv2/exiv2/issues/1529
- https://github.com/Exiv2/exiv2/pull/1534
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-v74w-h496-cgqm
- https://lists.debian.org/debian-lts-announce/2021/08/msg00028.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2XQT5F5IINTDYDAFGVGQZ7PMMLG7I5ZZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2A5GMJEXQ5Q76JK6F6VKK5JYCLVFGKN/
- https://security.gentoo.org/glsa/202312-06
- https://www.debian.org/security/2021/dsa-4958
- https://github.com/Exiv2/exiv2/issues/1529
- https://github.com/Exiv2/exiv2/pull/1534
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-v74w-h496-cgqm
- https://lists.debian.org/debian-lts-announce/2021/08/msg00028.html
Get alerted when CVE-2021-29457 or the next vulnerability affects your stack