What’s Vulnerable › Vulnerabilities
CVE-2021-29459: XSS Cross Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
Affected products
- xwiki-platform: before 12.6.3; from 12.6.4 before 12.8 — fixed in 12.6.3, 12.8
How to fix
Upgrade to a fixed version: xwiki-platform 12.6.3, 12.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-5c66-v29h-xjh8
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-5c66-v29h-xjh8
Get alerted when CVE-2021-29459 or the next vulnerability affects your stack