What’s Vulnerable › Vulnerabilities
CVE-2021-29478: Vulnerability in the COPY command for large intsets
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-04 · updated 2026-06-17
- Weakness: CWE-190
Description
Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis 6.2 before 6.2.3 could be exploited to corrupt the heap and potentially result with remote code execution. Redis 6.0 and earlier are not directly affected by this issue. The problem is fixed in version 6.2.3. An additional workaround to mitigate the problem without patching the `redis-server` executable is to prevent users from modifying the `set-max-intset-entries` configuration parameter. This can be done using ACL to restrict unprivileged users from using the `CONFIG SET` command.
Affected products
- Fedoraproject Fedora: 33, 34
- Redis Labs Redis: from 6.2.0 before 6.2.3 — fixed in 6.2.3
How to fix
Upgrade to a fixed version: Redis Labs Redis 6.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/security/advisories/GHSA-qh52-crrg-44g3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BPWBIZXA67JFIB63W2CNVVILCGIC2ME5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EZJ6JGQ2ETZB2DWTQSGCOGG7EF3ILV4V/
- https://redis.io/
- https://security.gentoo.org/glsa/202107-20
- https://github.com/redis/redis/security/advisories/GHSA-qh52-crrg-44g3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BPWBIZXA67JFIB63W2CNVVILCGIC2ME5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EZJ6JGQ2ETZB2DWTQSGCOGG7EF3ILV4V/
- https://redis.io/
- https://security.gentoo.org/glsa/202107-20
Get alerted when CVE-2021-29478 or the next vulnerability affects your stack