What’s Vulnerable › Vulnerabilities
CVE-2021-29489: Options structure open to XSS if passed unfiltered
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Highcharts JS is a JavaScript charting library based on SVG. In Highcharts versions 8 and earlier, the chart options structure was not systematically filtered for XSS vectors. The potential impact was that content from untrusted sources could execute code in the end user's browser. The vulnerability is patched in version 9. As a workaround, implementers who are not able to upgrade may apply DOMPurify recursively to the options structure to filter out malicious markup.
Affected products
- highcharts: before 9.0.0 — fixed in 9.0.0
- NetApp Cloud Backup: all versions
- OnCommand Insight: all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp SnapCenter: all versions
How to fix
Upgrade to a fixed version: highcharts 9.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/highcharts/highcharts/security/advisories/GHSA-8j65-4pcq-xq95
- https://security.netapp.com/advisory/ntap-20210622-0005/
- https://github.com/highcharts/highcharts/security/advisories/GHSA-8j65-4pcq-xq95
- https://security.netapp.com/advisory/ntap-20210622-0005/
Get alerted when CVE-2021-29489 or the next vulnerability affects your stack