What’s Vulnerable › Vulnerabilities
CVE-2021-29495: Nim stdlib httpClient does not validate peer certificates by default
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-07 · updated 2026-06-17
- Weakness: CWE-295
Description
Nim is a statically typed compiled systems programming language. In Nim standard library before 1.4.2, httpClient SSL/TLS certificate verification was disabled by default. Users can upgrade to version 1.4.2 to receive a patch or, as a workaround, set "verifyMode = CVerifyPeer" as documented.
Affected products
- nim-lang Nim: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: nim-lang Nim 1.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/nim-lang/security/security/advisories/GHSA-9vqv-2jj9-7mqr
- https://github.com/nim-lang/security/security/advisories/GHSA-9vqv-2jj9-7mqr
Get alerted when CVE-2021-29495 or the next vulnerability affects your stack