What’s Vulnerable › Vulnerabilities
CVE-2021-29501: Remote code execution in ticketer
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-10 · updated 2026-06-17
- Weakness: CWE-74
Description
Ticketer is a command based ticket system cog (plugin) for the red discord bot. A vulnerability allowing discord users to expose sensitive information has been found in the Ticketer cog. Please upgrade to version 1.0.1 as soon as possible. As a workaround users may unload the ticketer cog to disable the exploitable code.
Affected products
- Dav-Git Dav-Cogs: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Dav-Git Dav-Cogs 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/Dav-Git/Dav-Cogs/commit/3d54ef9b52ce03f139b7d6c1cc38c375e65593fd
- https://github.com/Dav-Git/Dav-Cogs/security/advisories/GHSA-r2cf-49r7-pfj7
- https://github.com/Dav-Git/Dav-Cogs/commit/3d54ef9b52ce03f139b7d6c1cc38c375e65593fd
- https://github.com/Dav-Git/Dav-Cogs/security/advisories/GHSA-r2cf-49r7-pfj7
Get alerted when CVE-2021-29501 or the next vulnerability affects your stack