What’s Vulnerable › Vulnerabilities
CVE-2021-29502: Remote code execution in the WarnSystem module of Laggrons-Dumb-Cogs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-10 · updated 2026-06-17
- Weakness: CWE-74
Description
WarnSystem is a cog (plugin) for the Red discord bot. A vulnerability has been found in the code that allows any user to access sensible informations by setting up a specific template which is not properly sanitized. The problem has been patched in version 1.3.18. Users should update and type `!warnsysteminfo` to check that their version is 1.3.18 or above. As a workaround users may unload the WarnSystem cog or disable the `!warnset description` command globally.
Affected products
- Warnsystem Project Warnsystem: before 1.3.18 — fixed in 1.3.18
How to fix
Upgrade to a fixed version: Warnsystem Project Warnsystem 1.3.18. Check the vendor advisory for mitigations.
References
- https://github.com/retke/Laggrons-Dumb-Cogs/commit/c79dd2cc879989cf2018e76ba2aad0baef3b4ec8
- https://github.com/retke/Laggrons-Dumb-Cogs/security/advisories/GHSA-834g-67vv-m9wq
- https://github.com/retke/Laggrons-Dumb-Cogs/commit/c79dd2cc879989cf2018e76ba2aad0baef3b4ec8
- https://github.com/retke/Laggrons-Dumb-Cogs/security/advisories/GHSA-834g-67vv-m9wq
Get alerted when CVE-2021-29502 or the next vulnerability affects your stack