What’s Vulnerable › Vulnerabilities
CVE-2021-29505: XStream is vulnerable to a Remote Command Execution attack
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 77.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-28 · updated 2026-10-07
- Weakness: CWE-94
Description
XStream is software for serializing Java objects to XML and back again. A vulnerability in XStream versions prior to 1.4.17 may allow a remote attacker has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types is affected. The vulnerability is patched in version 1.4.17.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 33, 34, 35
- SnapManager for Oracle: all versions
- Oracle Banking Cash Management: 14.2, 14.3, 14.5
- Oracle Banking Corporate Lending Process Management: 14.2.0, 14.3.0, 14.5.0
- Oracle Banking Credit Facilities Process Management: 14.2.0, 14.3.0, 14.5.0
- Oracle Banking Supply Chain Finance: 14.2.0
- Oracle Corporation Oracle Banking Trade Finance Process Management: 14.5.0
- Oracle Business Activity Monitoring: 11.1.1.9.0, 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Communications BRM - Elastic Charging Engine: 11.3, 12.0
- Oracle Corporation Oracle Communications Unified Inventory Management: 7.3.4, 7.3.5, 7.4.0, 7.4.1, 7.4.2
- Oracle Corporation Enterprise Manager Ops Center: 12.4.0.0
- Oracle Retail Customer Insights: 15.0.2, 16.0.2
- Oracle Corporation Retail Xstore Point of Service: 16.0.6, 17.0.4, 18.0.3, 19.0.2, 20.0.1
- Oracle Corporation Oracle WebCenter Portal: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle WebCenter Sites: 12.2.1.3.0, 12.2.1.4.0
- x-stream xstream: before 1.4.17 — fixed in 1.4.17
How to fix
Upgrade to a fixed version: x-stream xstream 1.4.17. Check the vendor advisory for mitigations.
References
- https://github.com/x-stream/xstream/commit/24fac82191292c6ae25f94508d28b9823f83624f
- https://github.com/x-stream/xstream/commit/f0c4a8d861b68ffc3119cfbbbd632deee624e227
- https://github.com/x-stream/xstream/security/advisories/GHSA-7chv-rrw6-w6fc
- https://lists.apache.org/thread.html/r8ee51debf7fd184b6a6b020dc31df25118b0aa612885f12fbe77f04f@%3Cdev.jmeter.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2021/07/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/22KVR6B5IZP3BGQ3HPWIO2FWWCKT3DHP
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PVPHZA7VW2RRSDCOIPP2W6O5ND254TU7
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QGXIU3YDPG6OGTDHMBLAFN7BPBERXREB
- https://security.netapp.com/advisory/ntap-20210708-0007
- https://www.debian.org/security/2021/dsa-5004
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujan2022.html
Get alerted when CVE-2021-29505 or the next vulnerability affects your stack