What’s Vulnerable › Vulnerabilities
CVE-2021-29506: Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-400
Description
GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304
Affected products
- com.graphhopper:graphhopper-web-bundle: from 2.0 before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: com.graphhopper:graphhopper-web-bundle 2.4. Check the vendor advisory for mitigations.
References
- https://github.com/graphhopper/graphhopper/commit/eb189be1fa7443ebf4ae881e737a18f818c95f41
- https://github.com/graphhopper/graphhopper/pull/2304
- https://github.com/graphhopper/graphhopper/security/advisories/GHSA-hf44-3mx6-vhhw
- https://github.com/graphhopper/graphhopper/commit/eb189be1fa7443ebf4ae881e737a18f818c95f41
- https://github.com/graphhopper/graphhopper/pull/2304
- https://github.com/graphhopper/graphhopper/security/advisories/GHSA-hf44-3mx6-vhhw
Get alerted when CVE-2021-29506 or the next vulnerability affects your stack