What’s Vulnerable › Vulnerabilities
CVE-2021-29509: Keepalive Connections Causing Denial Of Service in puma
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-11 · updated 2026-06-17
- Weakness: CWE-400
Description
Puma is a concurrent HTTP 1.1 server for Ruby/Rack applications. The fix for CVE-2019-16770 was incomplete. The original fix only protected existing connections that had already been accepted from having their requests starved by greedy persistent-connections saturating all threads in the same process. However, new connections may still be starved by greedy persistent-connections saturating all threads in all processes in the cluster. A `puma` server which received more concurrent `keep-alive` connections than the server had threads in its threadpool would service only a subset of connections, denying service to the unserved connections. This problem has been fixed in `puma` 4.3.8 and 5.3.1. Setting `queue_requests false` also fixes the issue. This is not advised when using `puma` without a reverse proxy, such as `nginx` or `apache`, because you will open yourself to slow client attacks (e.g. slowloris). The fix is very small and a git patch is available for those using unsupported versions of Puma.
Affected products
- Debian Linux: 10.0
- puma: before 4.3.8; from 5.0.0 before 5.3.1 — fixed in 4.3.8, 5.3.1
- Rubygems Puma: before 4.3.8; from 5.0.0 before 5.3.1; 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.9.1, 0.9.2 (+127) — fixed in 4.3.8, 5.3.1
How to fix
Upgrade to a fixed version: puma 4.3.8, 5.3.1; Rubygems Puma 4.3.8, 5.3.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/nateberkopec/4b3ea5676c0d70cbb37c82d54be25837
- https://github.com/puma/puma/security/advisories/GHSA-q28m-8xjw-8vr5
- https://github.com/puma/puma/security/policy
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://rubygems.org/gems/puma
- https://security.gentoo.org/glsa/202208-28
- https://gist.github.com/nateberkopec/4b3ea5676c0d70cbb37c82d54be25837
- https://github.com/puma/puma/security/advisories/GHSA-q28m-8xjw-8vr5
- https://github.com/puma/puma/security/policy
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://rubygems.org/gems/puma
- https://security.gentoo.org/glsa/202208-28
Get alerted when CVE-2021-29509 or the next vulnerability affects your stack