What’s Vulnerable › Vulnerabilities
CVE-2021-29613: Incomplete validation in `tf.raw_ops.CTCLoss`
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-665
Description
TensorFlow is an end-to-end open source platform for machine learning. Incomplete validation in `tf.raw_ops.CTCLoss` allows an attacker to trigger an OOB read from heap. The fix will be included in TensorFlow 2.5.0. We will also cherrypick these commits on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.1.4; from 2.2.0 before 2.2.3; from 2.3.0 before 2.3.3; from 2.4.0 before 2.4.2 — fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
How to fix
Upgrade to a fixed version: tensorflow 2.1.4, 2.2.3, 2.3.3, 2.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/14607c0707040d775e06b6817325640cb4b5864c
- https://github.com/tensorflow/tensorflow/commit/4504a081af71514bb1828048363e6540f797005b
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vvg4-vgrv-xfr7
- https://github.com/tensorflow/tensorflow/commit/14607c0707040d775e06b6817325640cb4b5864c
- https://github.com/tensorflow/tensorflow/commit/4504a081af71514bb1828048363e6540f797005b
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vvg4-vgrv-xfr7
Get alerted when CVE-2021-29613 or the next vulnerability affects your stack