What’s Vulnerable › Vulnerabilities
CVE-2021-29617: Crash in `tf.strings.substr` due to `CHECK`-fail
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-755
Description
TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a denial of service via `CHECK`-fail in `tf.strings.substr` with invalid arguments. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.1.4; from 2.2.0 before 2.2.3; from 2.3.0 before 2.3.3; from 2.4.0 before 2.4.2 — fixed in 2.1.4, 2.2.3, 2.3.3, 2.4.2
How to fix
Upgrade to a fixed version: tensorflow 2.1.4, 2.2.3, 2.3.3, 2.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/issues/46900
- https://github.com/tensorflow/issues/46974
- https://github.com/tensorflow/tensorflow/commit/890f7164b70354c57d40eda52dcdd7658677c09f
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mmq6-q8r3-48fm
- https://github.com/tensorflow/issues/46900
- https://github.com/tensorflow/issues/46974
- https://github.com/tensorflow/tensorflow/commit/890f7164b70354c57d40eda52dcdd7658677c09f
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mmq6-q8r3-48fm
Get alerted when CVE-2021-29617 or the next vulnerability affects your stack