What’s Vulnerable › Vulnerabilities
CVE-2021-29625: XSS in doc_link
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
Affected products
- vrana adminer: from 4.6.1 before 4.8.1 — fixed in 4.8.1
How to fix
Upgrade to a fixed version: vrana adminer 4.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/vrana/adminer/commit/4043092ec2c0de2258d60a99d0c5958637d051a7
- https://github.com/vrana/adminer/security/advisories/GHSA-2v82-5746-vwqc
- https://sourceforge.net/p/adminer/bugs-and-features/797/
- https://github.com/vrana/adminer/commit/4043092ec2c0de2258d60a99d0c5958637d051a7
- https://github.com/vrana/adminer/security/advisories/GHSA-2v82-5746-vwqc
- https://sourceforge.net/p/adminer/bugs-and-features/797/
Get alerted when CVE-2021-29625 or the next vulnerability affects your stack