What’s Vulnerable › Vulnerabilities
CVE-2021-29654
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-14 · updated 2026-06-17
- Weakness: CWE-502
Description
AjaxSearchPro before 4.20.8 allows Deserialization of Untrusted Data (in the import database feature of the administration panel), leading to Remote Code execution.
Affected products
- Stackpath Ajaxsearchpro: before 4.20.8 — fixed in 4.20.8
How to fix
Upgrade to a fixed version: Stackpath Ajaxsearchpro 4.20.8. Check the vendor advisory for mitigations.
References
- https://www.synacktiv.com/sites/default/files/2021-04/WP_AjaxSearchPro_Vulnerability.pdf
- https://www.synacktiv.com/sites/default/files/2021-04/WP_AjaxSearchPro_Vulnerability.pdf
Get alerted when CVE-2021-29654 or the next vulnerability affects your stack